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1. Introduction 

1.1. Scope and Purpose 

CHER-Ob was developed to meet the needs of the experts and researchers in the cultural 

heritage related fields. Those needs can be listed as Management of Large Scale of Data and 

Project, Analysis and Evaluation Tools, Documentation and Sharing. 

CHER-Ob provides a unified platform for heterogeneous documents of historical materials for a 

variety of users. In this platform users can view, interpret, comment and add new information 

collected as a result of different studies.  

The main conceptual features of the software are the Cultural Heritage Entity (CHE) and the 

Project. CHEs are user defined set of data and Projects are different types of studies focused on 

answering specific research questions about a single or plural CHE(s). Although simultaneous 

analysis of different types of digital images (2D, 3D, RTI and CT images- see section ‘3.2 

Compatible data types’, p.32) is possible in CHER-Ob, all the attributions are given to each 

image along with the classified information related to the CHE(s).The classification scheme is a 

simplified version of Getty Classification of Works of Art, that facilitates sharing of diverse 

nature of the documents by a variety of experts from different disciplines. The description of 

each class can be found in section ‘2.1.4 Tools’ (p.15) of this manual. 

CHE(s) are the main sources of data to be studied in CHER-Ob. CHE(s) files are collection of 

available information introduced to the software by the user, including image files and 

classified information. The study of the CHE(s) is done by defining a project and collecting all 

the necessary data under the Project File. These data may belong to one or more CHE(s), 

depending on the needs of the user who creates the project in CHER-Ob. The user then views, 

annotates and shares the files/images collected under the Project File. Annotations and Notes 

are searchable and the evolution of the projects can be tracked by the navigation tool. The 

customizable automatic reports generation feature helps to distribute the results of the project.  
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Figure 1. CHER-Ob. Process Overview. In Phase 1, the user creates a CHE, providing the already existing 

information followed by Phase 2, where the research questions are defined, leading to a creation of a project 

in Phase 3. During the development of the project, in Phase 4, the data are modified, new information is 

added until its completion in Phase 5, where the project is shared. 

 

The main objectives of this manual are to provide an initial orientation for working with CHER-

Ob and present its most important features. The manual begins with an overview of the CHER-

Ob’s user interface in section 2 (p. 5) and demonstrates typical methods for working with the 

various file types supported by CHER-Ob in section 3 (p. 32). Via exploring the sample CHER-Ob 

projects in section 4 (p. 40) the user can familiarize with the main concepts of the software. 

1.2. Installation 

For installation instructions please visit https://github.com/WeiqiJust/CHER-Ob.  

  

Phase 1: Cultural 
heritage Entity 

creation

Phase 2: 
Defining 
research 
questions

Phase 3: 
Project creation

Phase 4: Data 
modification

Phase 5: Sharing 
project 

https://github.com/WeiqiJust/CHER-Ob
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2. Interface 

When you open CHER-Ob for the first time, you will be greeted by an interface similar to the 

one in Figure 2, if you are running the software on Windows 7. If your screen resolution is too 

small, the right toolboxes will be merged with separate tabs (Figure 3). 

 

Figure 2. The initial appearance of CHER-Ob on Windows 7 at startup. 

 

 

Figure 3. The initial appearance of CHER-Ob on Windows 7 at lower resolution. 

When CHER-Ob works in Cultural Heritage Entity mode the acronym CHE appears on the title 

line just before the Cultural Heritage Entity’s name. In case of Project mode, the label Project 
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appears just before the project’s name (Figure 4). The tabs on the right hand of the screen are 

slightly differentiated.  The textual information is represented by the Cultural Heritage Entity 

Tab in Cultural Heritage Entities and by the Classified Info tab in Projects (Figure 5). The Project 

Info icon is deactivated in Cultural Heritage Entity mode (Figure 6). 

     

Figure 4. Label CHE just before Cultural Heritage Entity’s name “YBC7289” (left) and label Project just before 

the project’s name “3D Printing QR…” (right).  

 
 

 

Figure 5. The textual information is represented by the Cultural Heritage Entity Tab in Cultural Heritage 

Entities (above) and by the Classified Info tab in Projects (below). 

 

Figure 6. File Info (left) and Project info (right) icons.   

2.1. Menu 

An easy way to access all of the features of CHER-Ob is the menu bar (Figure 7). 



7 

 

 

Figure 7. The menu bar.   

2.1.1. File 

 File>New 

 New > Project…: Creates a new CHER-Ob Project 

 New > Cultural Heritage Entity…: Creates a new CHER-Ob Cultural 

Heritage Entity  

 

 

 

Figure 8. Create “New Project” dialog box.  

Add affiliation  

Add user name 

 

Import data 

Define user mode  

Add project’s name  

Add keywords  

Add location  

 

Add description   
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Figure 9. Create “New Cultural Heritage Entity” dialog box.  

 

Figure 10. After creating a “New Cultural Heritage Entity” the user can add information organized in 11 

categories.  

 

 Open 

 Open > Project…: Opens a dialog box to select and open an already existing 

CHER-Ob Project 

Import data 

Define user mode  

Add CHE’s name  

Add location  

 

Ph. Dimensions and shape 

descriptions  

 

Materials used for the 

creation, manufacture 

techniques 

 

Condition reporting, 

conservation treatment  

 

Objects and works related to 

the one described, type or 

relationship  

 

Visual and audio 

representations 

What the object/work of art or 

architecture is and its components, 

classification terms, titles and 

names  

 

Creator, date of creation, place of 

creation, culture  

 

Style/art movement, architectural, 

historical, archaeological context, 

subject matter, inscriptions 

 

 

Description-type of analysis, date, 

results  

 

Copyright, ownership, 

exhibitions/loans, copies 

 

 

User defined  
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 Open > Cultural Heritage Entity…: Opens a dialog box to select and open an 

already existing CHER-Ob Cultural Heritage Entity 

 Save: Saves the currently active CHER-Ob Project or Cultural Heritage Entity  

 Save as  

 Save Cultural Heritage Entity as…: Opens a dialog box to save the Cultural 

Heritage Entity with a different name, and/or at a different location, and/or 

under different user name (Figure 11) 

 Save Project as…: Opens a dialog box to save the Project with a different name, 

and/or at a different location, and/or under different user name (Figure 12).  

  

 

Figure 11. “Save Cultural Heritage Entity as” 
dialog box.  

 

Figure 12. “Save Project as” dialog box  

 

 

 Close: Closes the currently active CHER-Ob Project or Cultural Heritage Entity 

 Import  

 Object…: Opens a dialog box to select 3D, 2D and RTI imaging data  
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 CT Directory…: Opens a dialog box to open CT data and images. Instead of 

opening a specific file, you must navigate to the directory that contains the 

desired image(s), then press “Select Folder.”  

 Project…: Opens a dialog box to select a project  

 Cultural Heritage Entity…: Opens a dialog box to select a Cultural Heritage Entity 

 Merge Objects to Cultural Heritage Entity…: Opens a dialog box to select files to 

be merged to a Cultural Heritage Entity (Figure 13, Figure 14) 

 

Figure 13. “Merge Objects to Cultural Heritage Entity” dialog box. 

 

Figure 14. After selecting the objects to be merged a dialog box asks users to specify Cultural 
Heritage Entities.  
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 Remove: Opens a dialog box to select files to remove (Figure 15, Figure 16) 

 

Figure 15. “Remove Object” dialog box.  

 

Figure 16. After selecting the object to be removed a dialog box asks whether the selected 
object should be saved in another location.  

 

 Recent 

 Projects: Hover over this option and you can select and open any of the 8 most 

recent CHER-Ob projects.  

 Cultural Heritage Entity:  Hover over this option and you can select and open any 

of the 8 most recent CHER-Ob Cultural Heritage Entities. 

 Recent Files: Hover over this option and you can select and open any of the 8 

most recent files that CHER-Ob has displayed.  

 Exit: Closes the program. 
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The options Import Object and Import Project and Merge Objects to Cultural Heritage Entity are 

available only in Projects (Figure 17). 

   

Figure 17. The file menu for Projects (left) and Cultural Heritage Entities (right).   

2.1.2. Render 

This menu is only selectable when working with 3D meshes. 

 Rendering Mode (Figure 18) 

o Points: Displays the object as a mass of individual points or vertices. 

o Wireframe: Displays the object as a series of vertices connected by edges, giving 

the appearance of a collection of transparent polygons. 

o Surface: Displays the object as a series of connected polygons with smooth, flat 

faces in grayscale. 

o Texture: When selected, displays the overlying texture on the points, frame, or 

mesh (depending on which rendering mode you have chosen). When not 

selected, the object is displayed in gray- scale. If the file has no texture 

associated with it, toggling this option does nothing.  

 Lighting > Directional Light On/Off: Toggles the directional light. Turning this option off 

will bathe the object in constant illumination from all directions and give it a flat 
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appearance. Turning it on will project light only from the direction indicated by the 

sphere in the Light Control toolbox (Figure 19). 

 

Figure 18. Detail of a clay tablet from the Yale Babylonian Collection displayed in points, 
wireframe, texture and surface rendering modes. 

 
Figure 19. Clay tablet from the Yale Babylonian Collection displayed with directional light off 
(left) and on (right).  

2.1.3. View 

 Information: Toggles the display of information about the file and your viewing 

perspective in the bottom-left corner of the image panel. 

 Interpolation: Toggles whether the object texture or picture is displayed as a series of 

discrete pixels or whether it is smoothly interpolated, causing the image to appear soft 

and blurry. This option is set off by de- fault and not available for 2D medical images. 

 Reset View: Centers the picture or object and displays it at its original size. 
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 Zoom In: Changes the image panel to present a more close-up view of the picture or 

object. Zoom Out: Changes the image panel to present a more distant view of the 

picture or object. 

 View From: Hover over this option—only accessible when working with 3D meshes—

and you can change your viewing perspective to one of six predetermined positions 

around the object: front, left, right, top, bottom, and back. Note that selecting one of 

these positions will zoom the image panel in or out to present the object at its original 

field of view (Figure 20). 

 

Figure 20. Different views of a clay tablet 3D model from the Yale Babylonian Collection as 
presented in CHER-Ob.  
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t                                                                                           

left                                                                                     

 

top                                                                                     

 

right                                                                                     

 

bottom                                                                                   

 

back                                                                                           
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2.1.4. Tools  

This menu includes the following functions (Figure 21): 

 Generate report: exports the context of Projects and Cultural Heritage Entities in .pdf or 

.html format.  

 Show Polygon Indicator: Displays red lines to indicate the edges of the polygon currently 

under your cursor. 

 Measuring Tool: Displays the length between two points that you select, represented in 

the image panel as a straight orange line. The line drawn must begin at some point on 

the mesh. If you click outside the mesh to begin the line, the program will refuse and 

will draw the line beginning from the starting point of the last successful line that you 

drew, or from an arbitrary point on or near the mesh if this is the first line for this mesh 

(Figure 22). 

 Clear Measuring Tool: Clears the line drawn by the measuring tool and the distance 

displayed next to it. If View > Information is toggled on, the distance measured remains 

in the bottom-left corner of the image panel under the “Measured Distance” field. 

 

Figure 21. The tools menu  

 

Figure 22. Measuring the diameter of a clay tablet from the 
Yale Babylonian Collection. 

 Write annotation (Figure 23-Figure 25, Table 1) 

o Point note: Addition of annotation connected to a point 

o Surface note: Addition of annotation connected to a surface.   
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o Frustum note: Addition of annotation connected to a segment  

o Color:  Attributes each annotation to a particular color category.   

 

Figure 23. “Write annotation” menu.  

 

Figure 24. Point annotation (pink cross) and 
surface annotations (lime rectangles) on a 
2D image.  

 

Figure 25. Point (blue spot), surface (green 
rectangle) and volume (yellow) annotation 
on a 3D model.  
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Table 1. Color coding for annotations  

Color Category name Description 

Maroon  OBJECT What the object/work of art or architecture is 
and its components, classification terms, titles 
and names  

Red  MEASUREMENTS Physical dimensions (type, value, unit) and 
shape descriptions  

Orange  CREATION Creator, date of creation, place of creation, 
culture  

Yellow  MATERIALS Materials used for the creation, manufacture 
techniques 

Lime  DESCRIPTIONS Style/art movement, architectural, historical, 
archaeological context, subject matter, 
inscriptions 

Green  CONSERVATION Condition reporting, conservation treatment  

Aqua  ANALYSES Description-type of analysis, date, results  

Blue  RELATED Objects and works related to the one 
described, type or relationship  

Pink  ADMINISTRATION Copyright, ownership, exhibitions/loans, copies  

Purple  DOCUMENTATION Visual and audio representations  

White  USER DEFINED 

 

 Remove annotation: Deletes annotations  

 Filter annotation: Opens a dialog box to filter annotations according to user name 

(Figure 26) 
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 Screenshot: Saves a screenshot of the currently selected object.  

 Bookmark: Saves views of interest. Opens a dialog box for naming the bookmark (Figure 

27) 

 

Figure 26. “Filter annotations” dialog box 

 

Figure 27. “Bookmark” dialog box. 

 File Info: Displays the basic file information (Figure 28). 

 

Figure 28.File Info.  

 Project info: Displays the basic project information (Figure 29). 

 

Figure 29. Project Info.  
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2.1.5. Windows  

 Close all windows: closes all currently open windows. 

 Close current window: closes current window. 

 Open closed window: opens a dialog box for the selection of the object (Figure 31). 

 Tile: If more than one file is open, displays all of the open files in windowed mode inside 

the image panel. 

 Maximize: Displays only the active file at maximum size inside the image panel. 

 Next: If more than one file is open, displays the next file inside the image panel if you’re 

in maximized mode, or switches to the next file if you’re in windowed mode  

Below the “Next” menu option, there is a list of all files open in CHER-Ob. You can quickly 

switch to any given file by clicking on its title. 

 

Figure 30. The Windows menu. 

 

Figure 31. “Open closed window” dialog 
box.

 

2.1.6. Help 

Help: Presents the user with CHER-Ob’s help files, which are identical to this manual. 

About: Displays a small box containing information about the program. 

When you are viewing an image in maximized mode, the menu bar also contains three icons to 

the far right that allow you to alter the image display. 

 Minimize: Shrinks the image and displays the title bar at the bottom of the screen. 

 Restore Down: Displays the image panel in a small window and displays the other open 

files in windowed mode. 
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 Close: Closes the file. 

2.2. Icons 

The icons (Figure 32) shown between the drop-down menus and the image panel replicate 

most of the menus’ functionalities and commands.  

 

Figure 32. The icons bar in CHER-Ob.  

2.2.1. Project 

The two leftmost icons allow creating and opening a project . The icon  allows saving a 

project. 

2.2.2. Open 

The two icons  allow easy access to the dialog box for opening files. The first opens 2D 

and 3D images, and the second opens CT imaging data. 

2.2.3. Render 

The following five icons are only usable when working with 3D meshes. 

 Lightbulb: Toggles the directional light. 

 Points: Displays the mesh as a series of points or vertices. 

 Wireframe: Displays the mesh in wireframe mode. 

 Surface: Displays the surface polygons on the mesh. 

 Texture: Toggles the texture display. 

2.2.4. View 

These two icons alter what you see in the image panel when displaying an image. 

 Spiral: Toggles the use of interpolation on the picture or texture (Figure 33). 

 Info: Toggles the display of computer, image, and perspective information in the top-

left and bottom- left corners of the panel. 
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Figure 33. Close-up of a crack showing the difference between the pixelated image (left) and the 
smoothly interpolated image (right).  

2.2.5. Tools 

The measuring tools are for use with 3D meshes only. 

 Ruler: When selected, measures the length between two points that you select, at 

least one of which must be on the mesh. 

 Ruler/Eraser: Removes the line drawn by the measuring tool and the text indicating 

the line’s length from the image panel. 

2.2.6. Annotation and Screenshot 

The next icons allow creating ,color coding and deleting annotations , either point  , 

surface  or frustum   ones.  

You can use the  icon to take and save a screenshot. 

2.2.7. Bookmark View 

The icon  allows you to create a list of bookmarks for views of interest. The bookmark list 

created will appear under the “Bookmarks” tab at the bottom left corner. 

2.2.8. File and Project Info 

By clicking the icon , you will see the basic file information, which varies depending on the 

type of file, e.g., 2D or 3D. By contrast, clicking the icon  will bring you the basic information 

of the project. 



22 

 

2.2.9. Windows 

You can use the next three icons to navigate among multiple open files. 

 Tile: Displays all open files as tiles inside the image panel. 

 Maximize: Displays only the active file at maximum size inside the image panel 

(Figure 34). 

 Next: Displays the next picture or object in the image panel if in maximized mode, or 

makes the next picture or object the active project if in tile mode. 

2.2.10. Perspective 

The final six colored square icons are only usable when working with 3D meshes. They allow 

you to select a pre- determined position from which to view the mesh: 

 Front: “Fr” - red 

 Left: “Lf” - yellow 

 Right: “Rt” - green 

 Top: “Tp” - blue 

 Bottom: “Bt” - indigo 

 Back: “Bk” - violet 

 

Figure 34. Images displayed in tiled mode (left) and RTI image displayed in maximized mode 
(right).  
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2.3. Tabs 

2.3.1. Image Panel 

The image panel is where the picture or object that you select will be rendered. When a file is 

loaded, the panel consists of a black background upon which the open picture or object is 

displayed, as well as accompanying in- formation about the file and your system.  

The bottom-left corner of the panel contains data about the open image and your viewing 

perspective.  

2.3.2. Navigation Tab  

The navigation tab (Figure 35) is structured in a hierarchical mode and provides information 

about the:  

 Project name  

 Cultural Heritage Entities from which Objects are retrieved  

 A list of the Objects imported to Cultural Heritage Entities or Projects  

 A list of annotations attached to each Object  

 A list of Bookmarks  

The Navigation Tab in Cultural Heritage is exactly the same as the one in Projects, apart from 

the Project Name, and the list of Cultural Heritage Entities, which is limited to one.  Removed 

notes appear faded in the navigation tab. Right click on the faded note in the Navigation tab 

provides the option to undo the remove (Figure 36).  

 

Figure 35. The Navigation Tab of a Project.   
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Figure 36. Removed notes appear faded in the Navigation tab (left). Right click on the faded 
note in the Navigation tab provides the option to undo the remove (right).  

2.3.3. Cultural Heritage Entity and Classified Info Tab  

The Cultural Heritage Entity (Figure 37) and Classified Info Tabs (Figure 38) provide access to 

textual information about the Cultural Heritage Entities classified in 10 categories (for a 

description of the categories please see Table 1). The Cultural Heritage Entity Tab applies when 

CHER-Ob works in Cultural Heritage Entity mode. It is a dropdown list of the predefined 

categories associated to each Cultural Heritage Entity. The user can edit the text and export the 

context from a Cultural Heritage Entity to a Project.  The Classified Info tab is the equivalent for 

Projects. The user can select from a dropdown list the Cultural Heritage Entity and the category 

and access the relevant information. Edit option is available for Classified Info tab.  

 

Figure 37. The Cultural Heritage Entity Tab. 

 

Figure 38. The Classified Info Tab. 
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2.3.4. Application Tab  

The application tab contains the following 

(Figure 39): 

 Light control 3D and RTI 

 CT Image control  

 Spectrum 

 Annotation  

 Bookmarks  

 Search  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 39. Application Tab 
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2.3.4.1. Light Control 

The Light Control toolbox (Figure 40) is ordinarily at the right side of the application. Only some 

options, or none at all, may be available in this window depending on the type of active image. 

Please note that changing these settings will affect all open 3D images, not simply the active 

one. You can adjust the direction of light striking the image or object by clicking on the sphere 

to the left and dragging in the direction that you want to move the light source. The position of 

the yellow circle indicates the direction at which the light strikes the object and the point at 

which the illumination is greatest. The light direction can also be moved behind the sphere, 

providing a backlight effect to the object (Figure 41). To return to the toolbox’s default values, 

click the “Light Reset” button. This places the light direction at the front center of the sphere 

and sets the brightness and contrast to the median value of 50. 

 

Figure 40.  Light Control toolbox. Default settings.  

 

Figure 41. Examples of different light settings available in CHER-Ob. Default settings (right), 
directional light (middle) and enhanced brightness and lowered contrast (left).  
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2.3.4.2. Light control RTI  

The light RTI control toolbox provides the basic viewing features, such as the light controller, 

rendering modes (default, specular and normal map) and navigation options (zoom and pan) 

(Figure 42) 

2.3.4.3. CT Image Control 

This toolbox is only active when working with CT scanning data. You can use it to navigate 

through a series of 2D image slices or to select display options when working with 3D models. 

These options are only accessible when the “2D Rendering” mode is selected. From here, you 

can see the current slice that is displayed in the image panel, as well as the total number of 

slices available to scroll through. You can also change the view in the image panel to a front, 

side, or top perspective and flip the image upside down. Perhaps most importantly, you can 

navigate through the full range of slices by dragging the slider at the bottom from beginning to 

end and back again. If your image has many slices and the slider is not precise enough to 

navigate to your desired slice, you can also move more slowly through the slices with the left 

and right arrow keys. When you select the Volume Render radio button, the “2D Image Stack 

Control” options on the right side of the toolbox are deactivated and the “Vol. Rendering 

Control” options are activated. The second box allows you to change the blend type. Unless you 

want to work with a specific blend type (e.g. modes to better visualize CT scans of skin, bone, 

and muscle), you should likely leave this setting alone. Finally, you can change the resolution at 

which the object is displayed. If the image is rendering very slowly, selecting “Half resolution” 

or “Quarter resolution” may provide better performance for your machine (Figure 42). 

2.3.4.4. Spectrum 

The Spectrum toolbox (Figure 43), in case of standard RGB images, contains three meaningful 

data points; red, green and blue reflectance values. It is most useful when working with 

hyperspectral images and textures. The ultraviolet spectrum consists of those wavelengths to 

the left of the violet line on the graph, while the infrared spectrum appears to the right of the 

red line. It has no effect when working with 3D meshes with no texture or data in grayscale.  
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Figure 42. The Light RTI and CT control toolbox.   

 

 

Figure 43. The “Spectrum” toolbox 

To use the Spectrum toolbox, simply right-click on a given pixel or cell to display a graph of the 

available wave-lengths plotted against the reflectance values normalized into [0, 1]. By clicking 

the tick box  just under the graph, you can re-normalize the reflectance values so that 

the length of the vector that is composed of these original normalized reflectance values 

becomes 1 (Figure 44). 



29 

 

 

Figure 44. Reflectance graph of a point with adhesive residue before (left) and after 

normalization (right).  

By clicking the button  just left to the tick box , you can export some useful 

information associated with the point clicked. You will see a dialog immediately after clicking 

the “export” button, where comments can be added and will be exported (Figure 45). 

 

Figure 45. The dialog box that enables to add a label to the exported reflectance data.  

After exporting, two files (.png and .msa) will be generated into the same folder where the file 

exists. The PNG image shows the reflectance values against the wave-length (for example 

Figure 44 left), while the MSA file is actually a text file with a structure as shown in Figure 46. 
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Figure 46. Text file exported using the “Spectrum” toolbox.  

2.3.4.5. Annotations  

The ‘Annotation tab’ provides a general annotation that does not refer to a particular point, 

surface or volume but to the whole visualization. The tab displays the annotation for the 

currently active window (Figure 47).     

2.3.4.6. Bookmarks  

The ‘bookmarks tab’ provides a list of views of interest, assigned by the user. The tab displays 

the bookmarks for the currently active window (Figure 48).   

2.3.4.7. Search and Search all    

The ‘search and ‘search all tabs’ provide the option to search for a term either in the currently 

active window or the whole Cultural Heritage Entity or Project. Search results can be sorted and 

filtered based on the category (Figure 49).    



31 

 

 

Figure 47. The Annotation tab.   

 

Figure 48. The Bookmarks tab.   

 

Figure 49. The search tab.   
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3. Using CHER-Ob 

3.1. Navigation 

Image navigation within CHER-Ob is simple and intuitive: 

 To move the picture around the image panel, hold the Shift key down and drag the 

image with the left mouse button, or push down on the mouse scroll wheel and drag. 

 To zoom in, move the scroll wheel up, press Ctrl-Plus (+) on Windows or select View > 

Zoom In from the menu. 

 To zoom out, move the scroll wheel down, press Ctrl-Minus (-) on Windows or select 

View > Zoom Out from the menu. 

 To center the picture or object and display it at its original size, press Ctrl-0 on Windows 

or select View > Reset View from the menu. 

 To view the spectral information for the current pixel, click the right mouse button. This 

functionality is available for 2D images and 3D meshes with associated textures. 

 To rotate a 3D mesh, hold down the left mouse button and drag the mesh in the desired 

direction. This functionality is not available for 2D images. 

3.2. Compatible data types  

CHER-Ob can open 3D models in .obj,. wrl and .ply file format, 2D images in .png, .tif, .tiff, .bmp, 

.jpg, .jpeg, .exr and .bmp file format, RTI images in .ptm and .rti file format. and CT data. For the 

information displayed in the file info and the image panel info see Table 2. 

3.3. Working with different file types 

3.3.1. RTIs  

CHER-Ob allows users to load and examine RTI visualizations. It has basic RTI viewer features, 

such as the light controller, rendering modes, navigation options (zoom and pan), screenshot 

(snapshots) and bookmarks, but also simultaneously multiple RTI visualization both in .rti and 

.ptm file format. The annotation options for RTIs are point, area and general file annotations. 

The notes are searchable, and sortable, and can be attributed to one category for the 

descriptions of work of art. Certain RTI views can be revisited using bookmarks (Figure 50). 
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o For placing a point note right click the point on the image.  

o For placing a surface note select area.  

3.3.2. 2D Images  

The CHER-Ob screenshot shown in Figure 51 presents in tiled mode four different 2D images. 

On the upper left image panel, a photograph retrieved online from the web page of 2015 WEF 

in Davos showing the Pythagorean Tablet from the Yale Babylonian Collection and a Palmyran 

statue from the Smithsonian Institution. The general annotation provides information for the 

image such as context, location, date. The point annotation provides information for the online 

retrieval of the 3D model of the statue.  On the lower right image panel, a group of surface 

annotations explain the cuneiform writings with attached images. Individual details of the 

image have been bookmarked and screenshots have been created.  

o For placing a point note right click the point on the image.  

o For placing a surface note select area.  

3.3.3. 3D Models  

CHER-Ob can load more than one 3D models, that can be viewed in different rendering modes, 

annotated, bookmarked and related to a categorized textual information, either simultaneously 

at tiled mode or separately in full screen mode. Measurements and searches can be performed 

(Figure 52). 

o For placing a point note right click the point on the image.  

o For placing a surface note press ‘R’ and then select area.  

o For placing a frustrum note press ‘R’ and then select volume.  

3.3.4. CT data 

CHER-Ob allows users to load and examine CT data. It has basic viewer features in 2D stack and 

volume rendering modes, navigation options (zoom and pan), screenshot (snapshots) and 

bookmarks, but also simultaneously multiple CT images examination. The annotation options 

for CT are points, area and general file annotations. The notes are searchable, and sortable, and 
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can be attributed to one category for the descriptions of work of art. More functions for 

exploring CT data are coming soon.  

Table 2. Info displayed in file info and image panel info  

FILE 

TYPE 

FILE INFO IMAGE PANEL INFO 

2D Filename, File type, File size, Image dimensions, 

Number of codes 

Image coordinates and pixel 

values 

3D  Polygon ID: This field updates when the cursor moves 

to a new polygon. If the cursor is not currently over a 

polygon, this value is -1. Polygon Normal: The 

normalized x-, y-, and z-coordinates of the vector 

normal to the surface of the currently selected 

polygon. This field updates when the cursor moves to 

a new polygon. If the cursor is not currently over a 

polygon, this value is all zeros. Screen Coordinates: 

The physical pixel coordinates of the cursor’s current 

location, based on the resolution of the image panel. 

This field updates when the cursor moves to a new 

pixel. World Coordinates: The x-, y-, and z-

coordinates of the base primitive system for the 

overall 3D model that is the frame of reference for all 

other model coordinates. If the cursor is not 

currently over the mesh, this value is all zeros. 

Measured Distance: The length of the last line drawn 

by the measuring tool. If you have not used the 

measuring tool with the current object, this value is 0 

cm. Texture Coordinates: The pixel coordinates of the 

current texel (texture element) in the original 2D 

texture image. If the mesh has no texture, this value 

is blank. Screen Pixel Values: The RGB values of the 

pixel currently under the cursor. If the mesh has no 

texture, this value is blank. 

Geometry Filename: The 

name of the open file, 

without the file type 

extension. 

Texture Filename: The name 

of the 2D texture associated 

with the 3D mesh. If the 

mesh has no texture, this 

value is blank. Number of 

points. Number of polygons. 

Texture File Resolution: The 

first two values describe the 

width and height of the 

texture associated with the 

mesh; the third value is the 

number of channels in the 

image (e.g. 3 for RGB 

images). Model Info: The 

total number of points and 

polygons contained in the 

mesh. 
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Figure 50. Overview of features relevant to RTI visualizations.  
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Figure 51. Overview of features relevant to 2D images.  
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Figure 52. Overview of features relevant to 3D models. 
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3.4. Working with CHEs 

The main functions for working with CHEs are:   

 Create a CHE (File > New > Cultural Heritage Entity or Ctrl+Shift+N) 

 Fill the New Cultural Heritage Entity Dialog Box 

o Add user mode (creator, modifier, viewer) 

o Add user name (necessary field) 

o Browse objects 

o Add CHE name (necessary field) 

o Add location (necessary field) 

o Fill the 10 categories with already existing information about your Cultural 

Heritage Entity 

To modify the information, go to File > Save as… or Ctrl+Shift+S.  

To modify the textual information go to the Cultural Heritage Entity Tab.   

To add an object, go to File > Import object or Ctrl+I. 

To remove an object go to File > Remove object. 

To modify the image panel go to Windows menu. 

To modify the information added to the 10 categories go to the Cultural Heritage Entity Tab.   

 Explore rendering options in the Application Tab and/or Zoom/Pan.  

 Create annotations (Tools> Write annotation…). 

 Create bookmark (Tools> Bookmark view or ‘ ’). 

 Create screenshots (Tools> Screenshot or ‘ ’). 

 Navigate to the Cultural Heritage Entity (go to the Navigation Tab or the Windows menu 

or the ‘ ’). 

 Generate Report (Tools > Generate report…).  

 Search and/or Filter and/or Sort information (Application, Search/Search all tab). 

 Export to project (Cultural Heritage Entity Tab).  
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3.5. Developing CHER-Ob Projects 

The main functions for working with Projects are:   

 Create new project (File > New > Project or Ctrl+ N) 

 Fill the New Project Dialog Box 

 Add user mode (creator, modifier, viewer) 

 Add user name* 

 Browse objects 

 Add Project name* 

 Add location*  

 Add keywords 

 Add affiliation 

 Add project description  

The * indicates necessary fields.  

 To modify the information, go to File > Save as… or Ctrl+Shift+S.  

 To add an object, go to File > Import object or Ctrl+I. 

 To add CHE, go to File > Import CHE  

 To add an already existing Project, got to File> Import Project 

 To remove an object, go to File > Remove object. 

 To modify the image panel, go to Windows menu. 

 Explore rendering options in the Application Tab and/or Zoom/Pan.  

 Create annotations (Tools > Write annotation…). 

 Create bookmark (Tools > Bookmark view or ‘ ’). 

 Create screenshots Tools > Screenshot or ‘ ’). 

 Explore textual information for CHE (Classified Info Tab). 

 Navigate to the Cultural Heritage Entity (go to the Navigation Tab or the Windows menu 

or the ‘ ’). 

 Generate Report (Tools > Generate report…).  
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 Search and/or Filter and/or Sort information (Application, search/search all tab). 

 Update CHE information (File > Merge Objects to CHE).  

  

4. Explore the sample project: The Pythagorean Tablet   

4.1. CHE “YBC7289”  

4.1.1. Create 

i. Click File > New > Cultural Heritage Entity.  

ii. Fill the “Cultural Heritage Entity” Dialog box 

a. Add user mode and name  

b. Load objects (YBC7289_rev.rti; YBC7289_obv.rti; YBC7289_OBV.jpg; 

YBC7289_REV.jpg; ybc7289_simplified.ply) 

c. Specify location and name for CHE  

iii. Fill the categories with available information 

a. Object/work: tablet; hand tablet; cuneiform; Old Babylonian Period 

Mathematical Text. 

b. Physical dimensions/ measurements: max. diam. 72mm. round shape. 

c. Creation: Old Babylonian Period (1,900-1,700 B.C.E.); Mesopotamia; written by 

Babylonian student. 

d. Materials and techniques: The cuneiform writing was created by using a sharp 

stylus pressed into the surface of a soft clay tablet to produce wedge-like 

impressions representing numbers. 

e. Stylistic analysis and descriptions: The tablet shows a square with both 

diagonals. A number sign on the upper left indicates that the sides of the square 

are each 30 units long. Along the diagonal, we find the numerals 1,24,51,10 and 

42,25,35, both written, in accordance with the conventions of the Babylonian 

sexagesimal system, to base 60. The second of these numbers indicates the 

length of the diagonal. The first number, converted to a decimal, gives 

1.414212963, which is very close to v2, that is, 1.414213562. Apparently, the 
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student, to find out the length of the diagonal of a square whose sides were each 

30 units long, had calculated 30 [1;24,51,10], which yields 42;25,35. The tablet 

proves that the Babylonians of the early second millennium BCE knew that the 

ratio of the side to diagonal in a square is 1 to the square root of 2. They had 

come to this insight long before the Greek philosopher Pythagoras, who 

probably lived in the sixth century BCE, established his famous theorem a2 + b2 

= c2, which is behind their solution. The tablet demonstrates, moreover, that the 

mathematicians of the Old Babylonian era had found a remarkably good 

approximation to v2: 1;24,51,10. The student who wrote the tablet seems to 

have taken this number from a list of coefficients (one such list is likewise 

housed in the Yale Babylonian Collection). Fowler, D. and Robson, E., 1998. 

Square root approximations in old Babylonian mathematics: YBC 7289 in context. 

Historia Mathematica, 25(4), pp.366-378.; Aaboe, A., 1997. Episodes from the 

early history of mathematics (Vol. 13). MAA.; Neugebauer, O., Sachs, A.J. and 

Gotze, A., 1945. Mathematical cuneiform texts (Vol. 29). American Oriental 

Society. 

f. Condition and conservation: cracks; scratches; material loss; joined- remnants of 

adhesive material. 

g. Exhibition/ loans and legal issues: The tablet YBC 7289 came to Yale in 1909 as 

part of a much larger collection of cuneiform tablets assembled by J. Pierpont 

Morgan. 

h. Image/audio documentation: The tablet was digitized as part of the Babylonian 

Collection Digital Imaging Project using the following techniques: 1. reflectance 

transformation imaging (RTI), see files YBC7289_rev.rti and YBC7289_obv.rti 2. 

3D laser scanning, see file ybc7289.obj 3. high-resolution photography, see files 

YBC7289_REV.rti and YBC7289_OBV.rti Benjamin R. Foster, Holly Rushmeier 

(2014) Babylonian Collection Digital Imaging. Available at: 

http://digitalhumanities.yale.edu/projects/babylonian-collectiondigital-imaging 

http://digitalhumanities.yale.edu/projects/babylonian-collectiondigital-imaging
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4.1.2. Develop the CHE 

i. Add general annotations to the loaded objects (Figure 53).   

a. YBC7289_rev.rti and YBC7289_obv.rti: RTI of the tablet from the archive of the 

IPCH Digitization Lab. The tablet YBC 7289 was digitized as part of the Yale 

Babylonian Collection Digital Imaging Project in 2014. http://babylonian-

collection.yale.edu/history/current- projects http://ydc2.yale.edu/babylonian-

collection-digital-imaging- demonstration-project  

b. YBC7289_REV.jpg and YBC7289_OBV.jpg: Digital image of the tablet, form the 

archive of the IPCH Digitization Lab. The tablet YBC 7289 was digitized as part of 

the Yale Babylonian Collection Digital Imaging Project in 2014. http://babylonian-

collection.yale.edu/history/current- projects http://ydc2.yale.edu/babylonian-

collection-digital-imaging- demonstration-project  

c. ybc7289.ply: Simplified 3D model of the tablet. The model will be replaced by a 

high resolution 3D scan from the archive of the IPCH Digitization Lab, digitized as 

part of the Yale Babylonian Collection Digital Imaging Project in 2014. 

http://babylonian-collection.yale.edu/history/current- projects 

http://ydc2.yale.edu/babylonian-collection-digital-imaging- demonstration-

project. 

ii.  Explore RTI visualizations 

a. Use the “Light control RTI” for adjusting the light controller and rendering modes 

(Figure 54). 

b. Add surface annotations under the category “Stylistic analysis and descriptions” 

for the translation of cuneiform writings. Images attached to the annotations 

provide a clear representation of the cuneiforms (Figure 55). 

c. Create screenshots for areas of interest (Figure 56). 

iii. Explore the 3D model.  

a. Use the “Light control 3D” for adjusting the light direction, brightness and 

contrast of your display and navigate around different views of the model (Figure 

57). 
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b. Add a frustrum annotation for the label under the category “Exhibitions/loans 

and legal issues” and surface annotation under the category “Stylistic analysis 

and descriptions” for the translation of cuneiform writings. A drawing attached 

to the annotations provide a clear representation of the cuneiforms (Figure 58). 

iv. Explore 2D images 

a. Add surface annotations  

b. Add bookmarks 

c. Create screenshots  

v. Perform search  

a. Search for a particular term in a single object (Figure 62). 

b. Search for a particular term in the whole CHE (Figure 63). 

c. Filter your results based on a particular category (Figure 64).     

4.1.3. Export 

i. Create Reports  

a. For a complete report on the CHE, click Tools < Generate report and in the dialog 

box click select all.  

b. In the dialog box select the. ply file for a report on the 3D model (Figure 65) 

 

Figure 53. Application Tab. Detail showing a general annotation for the RTI visualization of 
the tablet YBC7289.  
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Figure 54. Exploring the RTI visualization. Different rendering modes light controller positions.  

 

Figure 55. A zoom view of the tablet showing a surface annotation of lime color, under the 
category “Stylistic analysis and descriptions” (left) and the annotation window showing the 
comment and the attached image (right).  

 

Figure 56. Screenshot of back side of tablet in specular enhancement rendering mode.  
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Figure 57. Exploring the 3D model.  

 

Figure 58. 3D model annotation window. 
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Figure 59. Annotated 2D image 

 

Figure 60. Application Tab. Detail showing list of bookmarks. 

  

Figure 61. Screenshot showing detail of cuneiform writings  
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Figure 62. Search results for the word 30 in the 2D image of the tablet.  

 

Figure 63. Search results for the word 30 in the whole CHE. 

 

Figure 64. Search result for the phrase Digital Imaging Project in the whole CHE and filtered only 
in general annotations. 
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Figure 65. Report part showing all the annotations of the 3D model.  
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4.2. CHE “QR coded 3D prints” 

4.2.1. Create  

i. Click File> New> Cultural Heritage Entity.  

ii. Fill the “Cultural Heritage Entity” Dialog box 

a. Add user mode and name  

b. Load objects (QRCODE_SAMPLES.jpg; QR_sample_2cm.wrl) 

c. Specify location and name for CHE  

iii. Fill the categories with available information 

a. Object/work: 3d model of a QR coded rectangle.  

b. Physical dimensions/ measurements: 3D printed in four sizes: 1.3, 1.5, 1.8, 2 cm. 

c. Creation: Created in Yale IPCH on December 2015. 

d. Materials and techniques: 3d model created in 3DS max, textured mapped and 

exported in wrl format in accordance with 3D printing requirement. 

e. Stylistic analysis and descriptions: Linked to http://ipch.yale.edu/news/3d-print-

ancient-history-one-most-famous-mathematical-texts-mesopotamia. 

f. Exhibition/ loans and legal issues: Yale IPCH. 

After loading the two objects will appear on your screen in tiled mode (Figure 66). 

Revisit the information classified in the categories on the Cultural Heritage Entity Tab 

(Figure 67).   

4.2.2. Develop the CHE 

i. Add general annotations to the loaded objects  

a. QRCODE_SAMPLES.jpg: 2D image of 3D print samples in full colour sandstone 

material, printed by shapeways. size 1.3 x 1.3 cm. to max 2 x 2 cm (Figure 68). 

b. QR_sample_2cm.wrl: 3D model of QR coded box.    

ii. Annotate the 2D image (Figure 69) 

http://ipch.yale.edu/news/3d-print-ancient-history-one-most-famous-mathematical-texts-mesopotamia
http://ipch.yale.edu/news/3d-print-ancient-history-one-most-famous-mathematical-texts-mesopotamia
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a. Specify the dimensions of the 3D prints depicted using point annotations under 

the category “Physical Dimensions / Measurements”, represented by the red 

cross symbol.  

b. Specify the readability of the 3D prints using surface annotations under the 

category “Stylistic Analysis and Descriptions”, represented by the green 

rectangle symbol.  

ii. Annotate the 3D model (Figure 70) 

a. Add a surface annotation to the 3D model and attach the 2D image of the 

texture mapped QR code generated in http://www.qrcode-monkey.com/  

You can access easily the models and the annotations on the Navigation Tab (Figure 71). 

 

 

Figure 66. The initial stage of CHE.  

http://www.qrcode-monkey.com/
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Figure 67. Cultural Heritage Entity Tab. Select category from the dropdown list and view and/or 
edit the existing information.  

 

Figure 68. General annotation 

 

Figure 69. Screenshot of annotated 2D image.  
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Figure 70. Screenshot of annotated 3D model and annotation window with attached 2D image.  

 

Figure 71. The Navigation Tab. 

4.3. Project “3D Printing QR Coded Tablet YBC 7289” 

4.3.1. Create  

i. Click File> New> Project.  

ii. Fill the “New Project” Dialog box providing information about  

a. the users and their affiliation, 

b. the project description and keywords 

c. the project name and location 

The Project “3D Printing QR Coded Tablet YBC 7289” aims to document and 

assist in decision making regarding the QR coding of the 3D model of the tablet 

YBC 7289 and its 3d printing. The technological and object oriented 
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requirements taken under consideration. The former consists of the size, shape, 

color and texture of the surface which hosts the QR code, the overall size of the 

3d print and its material. The latter include the positioning of the QR code 

rectangle, its size, shape and color in relation to the object and the overall size in 

relation to the real object. You can revisit the project info by clicking Tools< 

Project Info or the Project info icon (Figure 72).   

iii. Import files 

a. Click File< Import Object for loading two QR coded 3D models and two 2D 

images.  

b. Click File< Import Cultural heritage entity and select the 3D model (ybc7289.ply) 

from the CHE “YBC7289”  

c. Click File< Import Cultural heritage entity and select the 2D image 

(QRCODE_SAMPLES.jpg) from the CHE “QR coded 3D prints” 

After loading the files the Project appears on the screen in tiled mode as shown 

in Figure 73. Along with the files the project contains the annotations (Figure 74) 

and textual information deriving from each CHE accessible via the “The Classified 

info” tab (Figure 75).  The provenance of each file can be easily tracked via the 

Navigation Tab (Figure 76). 

4.3.2. Develop Project  

i. Explore the objects 

a. The two QR coded 3D models of the tablet were examined in parallel with the 

scanned 3D model (Figure 77). Via the measurement tool (Figure 78) and the 

annotations (Figure 79), the user reach conclusions regarding the positioning of 

the QR code rectangle. Adding annotations taking under consideration the 

object-oriented and the technical requirements. The former derive from the CHE 

“YBC7289” and the latter from the CHE “QR Coded 3d prints”. A small QR code 

rectangle positioned on the reverse side of the tablet does not cover the 

cuneiform inscriptions, it is elevated and clearly distinguished but not dominant, 

mainly because of its size in relation to the size of the tablet. The presence of the 
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2D images of the 3D printed tablets provide the necessary documentation for 

the project (Figure 80). 

4.3.3. Export  

i. Generate automatic report:  

a. Click Tools < Generate report, select location and give a filename and choose file 

type (.pdf or .html) for exporting your project for presentation, online publishing, 

digital and print archiving and collaboration purposes (Figure 81). 

ii. Updating CHEs  

a. Click File< Merge Objects back to CHE, select objects and specify location (Figure 

82). The updated CHE includes the new files (Figure 83). In addition, more textual 

information can be included in the ‘Cultural Heritage Entity Tab’ (Figure 84).  

 

Figure 72. Project Info 

 

Figure 73. Initial stage of project after loading objects and CHEs. 
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Figure 74. The annotations from the CHE are accessible in the Project.  
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Figure 75. The classified info tab.  

 

Figure 76. Navigation Tab   
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Figure 77. In parallel examination of the two QR Coded tablets  

 

Figure 78. Measurements on the 3D models.  
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Figure 79. Adding annotations.  

 

Figure 80. 2D images of the 3D printed tablets from the UNGC and the WEF.  
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Figure 81. Screenshot of the exported report in .html format.  

 

Figure 82. Merge object back to CHE dialog box and “Specify location” dialog box. 
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Figure 83. The Navigation Tab with highlighted updated files.  

 

Figure 84. Updating textual information of CHE YBC7289, by adding the information about the 

3D printed QR coded tablets under the “Related works” category.  

 

Updated files 
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5. Technical support 

5.1. Troubleshooting 

Q: What operating systems are required to open the software?  

A: Currently CHER-Ob supports windows and Mac OS X.  

Q: How can I compile CHER-Ob from the source code?  

A: First, you can find the source code on github https://github.com/WeiqiJust/CHER-Ob. After 

download the source code, you need to install necessary libraries. We provide all post-compiled 

libraries except QT in the lib folder. Notice all the libraries provided are compiled using win32-

msvc2008 with “Release x64”. The list of necessary libraries can be found in Readme.md in the lib 

folder. After the installation is done, for windows you can open the .sln file in windows folder using 

Visual Studio and rebuild the solution, for Mac OS, you can use .pro file under Mac folder to rebuild 

the project. 

Q: During compilation, the system notice me that there are some files cannot be opened. How 

should I solve this problem? 

A: Either the source files or the included files from libraries are not loaded correctly will lead to this 

problem. For the source files, they have already been loaded into the project .sln file. Please do not 

move and files in src/icons/images folders. For the included files, please make sure the paths and 

environment settings are correct. More details can be find in Readme 

(https://github.com/WeiqiJust/CHER-Ob). 

Q: After compilation, the system notice me that there are some .lib or .dll files are missing, what 

should I do? 

A:  The problem is caused by library link and configuration error. You need to provide correct paths 

to the library .lib or .dll files so that your compiler can find these files. More details please refer to 

https://github.com/WeiqiJust/CHER-Ob. 

Q: What kinds of data format are supported in CHER-Ob? 
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A: CHER-Ob provides support for various data formats, including 2D images (.png, .tif, .tiff, .bmp, 

.jpg, .jpeg, .exr), 3D models (.obj, .ply, .wrl), RTI (.ptm, .rti,) and CT data. 

Q: I created a project and in the project folder, I found some .txt and .xml files. Can I modify or 

move them? 

A: Please do not move or make changes to any files created by CHER-Ob outside the software. 

These modifications will lead to the errors of locating and opening these file in the software. 

Q: I can’t open my medical imaging data! 

A: As noted above, CHER-Ob is only able to display medical images that are compliant with the 

DICOM standard. We apologize for the inconvenience. 

Q: Why is only part of my .obj or .wrl file showing up? 

A: CHER-Ob currently does not support the display of objects with multiple textures or multiple 

objects in the same .obj or .wrl file. This is a feature that we would like to add in future releases. 

Q: My OpenEXR image is in grayscale or looks washed out! 

A: As noted above, CHER-Ob can only display images with YCBCR encoding in grayscale. We 

apologize for the inconvenience and may add this feature in future releases. 

Q: CHER-Ob crashed! 

A: CHER-Ob may crash when your computer has insufficient memory to handle all of the files open 

in the software at once. Please make sure that you are not using too much memory by monitoring 

the Performance tab in the Windows Task Monitor.  

If the crash is not caused by a memory issue, please see the following about seeking technical 

assistance. 

5.2. Problems and Questions 

Source code can be find in both GitHub (https://github.com/WeiqiJust/CHER-Ob). Bug reports 

can be posted on our GitHub Issue page or contact us (cher_ob@cs.yale.edu). If possible, please 
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include the file(s) that may help us reproduce the error and a description of your actions 

leading up to the problem.  

If you need technical support or you have questions or suggestions regarding the software or its 

manual, please make a post in our GitHub Issue page. Please use this as your primary resource 

for assistance, as the questions and answers posted there may help other users with similar 

issues.  

As a last resort, you may email cher_ob@cs.yale.edu for any problems and further cooperation. 

Please include the term “CHER-Ob” in the subject line of your email or it may not be answered. 

We ask you to ensure that an answer to your issue is not already available in these pages or on 

the forums before sending your message. 
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